HƯỚNG DẪN CÀI ĐẶT IPV6 CHO WIN7, CÁCH ĐẶT ĐỊA CHỈ IPV6 VÀ CÁCH SỬ DỤNG HIỆU QUẢ

-

IPv6 là giao thức Internet Protocol (IP) tiếp theo, được thiết kế để giải quyết vấn đề về hạn chế số lượng địa chỉ IP có sẵn trong IPv4, vì nó chỉ có khoảng 4,3 tỷ địa chỉ khả dụng. IPv6 cung cấp hàng tỷ lượng địa chỉ IP khổng lồ hơn, do đó có thể đáp ứng tốt hơn nhu cầu của thiết bị mới và các hệ thống không dây. Trong bài viết này, BKHOST sẽ giải thích IPv6 là gì? Cấu trúc địa chỉ IPv6 và những lợi ích khi sử dụng IPv6.

Bạn đang xem: Cài đặt ipv6 cho win7

IPv6 là gì?

IPv6 là phiên bản tiếp theo của giao thức Internet Protocol (IP), mà được sử dụng để điều hướng gói tin trên mạng Internet. Nó được thiết kế để thay thế cho IPv4, giao thức hiện tại được sử dụng rộng rãi nhất trên thế giới.

IPv6 được sử dụng để giải quyết vấn đề về hạn chế số lượng địa chỉ IP có sẵn trong IPv4. Vì IPv4 chỉ có khoảng 4,3 tỷ địa chỉ khả dụng, nên không thể đáp ứng được nhu cầu của các thiết bị mới đang liên tục được kết nối vào Internet. IPv6 cung cấp hàng tỷ lượng địa chỉ IP khổng lồ hơn, do đó có thể đáp ứng tốt hơn nhu cầu của thiết bị mới và các hệ thống không dây.

Việc sử dụng IPv6 cũng có thể giúp cho việc truyền dữ liệu trên mạng được nhanh hơn, vì nó có thể xử lý các gói tin nhanh hơn so với IPv4. Nó cũng có thể giúp cho việc triển khai các dịch vụ mạng mới và nâng cao hiệu suất mạng hiệu quả hơn.

Tuy nhiên, IPv6 vẫn chưa được sử dụng rộng rãi trên Internet, và nhiều trang web và dịch vụ vẫn chỉ hỗ trợ IPv4. Điều này có nghĩa là người dùng cần phải có một kết nối IPv4 để truy cập vào các trang web và dịch vụ này. Tuy nhiên, việc sử dụng IPv6 đang tăng dần và có thể trong tương lai sẽ trở thành giao thức chuẩn được sử dụng rộng rãi trên Internet.

Lợi ích của IPv6 là gì?

Để hình dung rõ hơn lợi ích IPv6 mang lại, chúng ta sẽ đến với những công dụng sau đây của IPv6:

IPv4 chỉ có 32 bit nên chỉ có thể cung cấp 4 tỷ địa chỉ IP. Còn IPv6 có đến 128 bit nên có thể cung cấp đến 2128 địa chỉ IP. Đây là một con số khổng lồ có thể đáp ứng tốt hơn nhu cầu của các thiết bị mới đang liên tục được kết nối vào Internet.Giúp cho việc truyền dữ liệu trên mạng được nhanh hơn, vì nó có thể xử lý các gói tin nhanh hơn so với IPv4.Giúp cho việc triển khai các dịch vụ mạng mới và nâng cao hiệu suất mạng hiệu quả hơn.Hỗ trợ các thiết bị không dây và các hệ thống không dây, giúp cho việc kết nối và trao đổi dữ liệu trên mạng không dây được thuận tiện hơn.

Cấu trúc địa chỉ IPv6 như thế nào?

Cấu trúc địa chỉ IPv6 gồm 8 phần, mỗi phần có độ dài là 16 bit (2 byte). Tổng cộng có 128 bit, còn nhiều hơn gấp đôi so với IPv4, có 32 bit (4 byte). Mỗi phần địa chỉ IPv6 được ngăn cách bởi dấu gạch ngang (-). Ví dụ, một địa chỉ IPv6 có thể là:

2001:0db8:85a3:0000:0000:8a2e:0370:7334.

Địa chỉ IPv6 cũng có thể được viết dưới dạng “shorthand notation” để giảm bớt số lượng ký tự. Trong trường hợp này, các phần có giá trị là 0 sẽ bỏ qua và các dấu gạch ngang (-) sẽ bỏ qua. Ví dụ, địa chỉ IPv6 trên có thể được viết lại như sau: 2001:db8:85a3::8a2e:370:7334.

*

Các thành phần của IPv6

Địa chỉ IPv6 có 3 thành phần:

Prefix: Là phần đầu của địa chỉ IPv6, gọi là “prefix”, có thể được sử dụng để xác định một mạng lớn hơn.Subnet ID: là một bộ phận có cấu trúc giống với một mạng đơn nằm bên trong web đóng vai trò thể hiện cấu trúc site của mạng. .Interface identifier: Là phần còn lại của địa chỉ IPv6, định danh duy nhất cho một thiết bị trên mạng.

*

Ví dụ:

Một địa chỉ IP thuộc IPv6 như sau: 2001:0f68:0000:0000:0000:0000:1986:69af

Trong đó:

Site prefix: 2001:0f68:0000Subnet ID: 0000Interface ID: 0000:0000:1986:69af

Phân loại địa chỉ IPv6

Địa chỉ IPv6 được chia thành 3 loại sau đây:

Unicast:

Địa chỉ Unicast là loại địa chỉ IPv6 được sử dụng trong một mạng nội bộ (private network). Địa chỉ local unicast không được phân bố trên toàn cầu và chỉ có thể được sử dụng trong mạng cụ thể đó.

Multicast:

Địa chỉ Multicast là loại địa chỉ IPv6 được sử dụng để gửi tin tới nhiều thiết bị cùng một lúc. Địa chỉ multicast được dạng bắt đầu bằng FF.

Anycast:

Địa chỉ Anycast là loại địa chỉ IPv6 được sử dụng để gửi tin tới một thiết bị duy nhất trong một nhóm các thiết bị. Địa chỉ anycast không có dạng cụ thể cụ thể nhất định, vì nó là một địa chỉ đặc biệt được sử dụng trong một nhóm các thiết bị.

Cách cấu hình IPv6 trên Windows Server

Đối với Windows Server, có 2 cách để gán địa chỉ IPv6 đó là cách thủ công và cách dùng cấu hình DHCPv6.

Hướng dẫn gán địa chỉ IPv6 thủ công

Đối với cách thủ công, bạn có thể áp dụng cho 2 hệ điều hành Windows Server 2012 có hoặc không có R2. Có 2 cách trong trường hợp này đó là sử dụng TCP/IPv6 hoặc Windows Power
Shell
.

Cách 1: Sử dụng Internet Protocol Version 6 (TCP/IPv6)Cách này trước tiên bạn phải vào hộp thoại TCP/IPv6 Properties.Hãy tìm biểu tượng wifi trên taskbar rồi nhấn chuột phải rồi chọn Open network and sharing center.Tiếp theo hãy vào Change adapter settings, nhấn chuột phải vào chỗ mạng rồi chọn Properties.Tiếp theo nhấn chọn Internet Protocol Version 6 (TCP/IPv6) rồi vào Properties.

*

Cách 2: Cấu hình IPv6 thủ công bằng Windows Power
Shell

Để minh họa cụ thể, dưới đây sẽ là ví dụ cấu hình thủ công bằng Windows Power
Shell cho địa chỉ IPv6. Việc cấu hình này sẽ được thực hiện trên Interface vật lý của máy.

Trước tiên là chạy Ipconfig ở máy chủ, khi đó sẽ ra giống thế này:

{{EJS0}}Trong đó:

Interface này được gán địa chỉ IPv4 là 172.16.11.75Địa chỉ link local IPv6 là fe80::2025:61fb:b68:c266%12

Ở cuối địa chỉ link-local IPv6 bạn sẽ thấy có %12. Đây là Zone identifier, trên Windows nó tương tự chỉ mục của Interface và dùng để xác định các liên kết trên địa chỉ. Khi dùng lệnh cmdlet Get-Net
Adapter
, bạn có thể xem được những chỉ mục và tên của những Interface vật lý ở máy bạn. Ví dụ cụ thể bên dưới đây:

PS C:\> Get-Net
Adapter | fl Name,if
IndexName : Ethernetif
Index : 12

Ngoài ra, bạn cũng có thể dùng cmdlet Get-Net
IPAddress để xem địa chỉ của Interface vật lý Ethernet. Cách này sẽ cho bạn biết nhiều thứ hơn là dùng lệnh Ipconfig.

{{EJS1}}Lệnh cmdlet New Net
IPAddress có thể dùng để gán địa chỉ Unicast IPv6 global và gateway. Dưới đây là minh họa gán địa chỉ Unicast mới có độ dài tiền tố là 64 và gateway mặc định cho “Ethernet”:

{{EJS2}}Như vậy là phần cài đặt đã xong. Để xem và xác nhận lại kết quả, bạn có thể dùng lệnh Get-Net
IPAddress cùng tham số Address
Family
để xem thông tin hiển thị IPv6 như bên dưới:

{{EJS3}}Bây giờ thì Interface Ethernet đã có địa chỉ IPv6 link-local và IPv6 global. Khi kiểm tra thông tin trong TCP/IPv6 Properties, thông tin hiển thị sẽ giống như hình dưới đây và Ethernet đã có thể kết nối mạng.

*

Cấu hình máy chủ DHCPv6

Cách cấu hình máy chủ DHCPv6 có thể áp dụng cho các hệ điều hành Window Server 2008, 2008 R2, 2012, 2012 R2. Bằng cách cấu hình này, bạn có thể cấu hình địa chỉ IPv6 có trạng thái hoặc phi trạng thái đều được. Cách thực hiện gồm 3 bước như sau:

Bước 1: Cài đặt vai trò cho DHCP server.

Bước 2: Gán địa chỉ tĩnh cho các Interface trên DHCPv6. Việc gán địa chỉ tĩnh này nhằm mục đích biết được những yêu cầu được gửi đến DHCPv6.

Bước 3: Vào phần DHCP, nhấn vào mục máy chủ và vào phần IPv6. Lúc này sẽ có 3 lựa chọn cài đặt cấu hình:

Cài đặt cấu hình tự động cho các địa chỉ phi trạng thái: Nhấp chuột phải vào Server Options trong IPv6 rồi nhấn Configure Options:

*

*

Cài đặt cấu hình tự động địa chỉ có trạng thái: nhấn chuột phải vào mục IPv6 và nhấn vào dòng New Scope:

*

Tiếp theo dùng New Scope Wizard cấu hình những thông tin cần thiết.

Hướng dẫn cách đặt địa chỉ IPv6 cho win 7, 8, 10

Để đặt địa chỉ IPv6 cho các hệ điều hành Windows 7, 8, 10, bạn hãy thực hiện theo 5 bước sau:

Bước 1: Mở Run và nhập ncpa.cpl rồi nhấn OK.

Bước 2: Click chuột phải vào card mạng bạn muốn cài IPv6 rồi chọn Properties.

Bước 3: Nhấn dấu tích vào ô Internet Protocol Version 6 (TCP/IPv6), sau đó nhấn nút Properties.

Bước 4: Điền các thông số địa chỉ IPv6 bạn muốn cấu hình.

Xem thêm: Pô Ex 150 Giả Zin Kozi Cho Yamaha Exciter 150, Pô Tăng Exciter 150 Giả Zin Nổ Ấm

Bước 5: Các bước cài đặt đã xong, bây giờ bạn có thể ping để xem kết quả IPv6 có được cài đặt đúng hay chưa. Hãy vào cmdipconfig, bạn sẽ thấy giống như hình dưới đây.

Tiếp theo gõ ping -6 ipv6.google.com

Nếu thấy có kết quả trả lời từ hệ thống thì có nghĩa là việc cài đặt đã thành công.

Hướng dẫn kiểm tra kết nối IPv6

Việc kiểm tra kết nối IPv6 sẽ có 2 đối tượng là kiểm tra nhà mạng và kiểm tra máy tính của bạn. Cách làm cụ thể cho 2 trường hợp đó như sau:

Hướng dẫn kiểm tra IPv6 của nhà mạng

Cách kiểm tra IPv6 nhà mạng rất đơn giản, bạn chỉ cần vào địa chỉ http://test-ipv6.com để kiểm tra. Khi kiểm tra bằng cách này, bạn sẽ biết được thiết bị của bạn đang sử dụng Internet bằng IPv4 hay IPv6. Ngoài ra, bạn sẽ còn được biết địa chỉ IP, tên nhà mạng bạn đang dùng và khả năng truy cập những web sử dụng IPv6 như thế nào.

Hướng dẫn kiểm tra máy tính bạn đã sẵn sàng với IPv6 chưa

Đối với máy tính, bạn sẽ có 2 cách để kiểm tra là dùng 1 trong 2 địa chỉ ipv6test.google.com hoặc ipv6-test.com.

Cách 1: Sử dụng địa chỉ ipv6test.google.com

*

Đây là công cụ kiểm tra kết nối IPv6 trên máy tính mà Google tạo ra để hỗ trợ người dùng. Nếu kết quả là bạn chưa kết nối IPv6 thì công cụ này cũng sẽ cho biết là việc truy cập các web chạy IPv6 có gặp vấn đề gì hay không.

Cách 2: Sử dụng địa chỉ ipv6-test.com

*

Cách này sẽ giúp bạn biết được máy tính của mình đang chạy IPv6 hay IPv4, địa chỉ IP, tên nhà mạng và khả năng vào các web chạy IPv6 có gặp vấn đề gì hay không. Tuy nhiên công cụ này còn kiểm tra một đặc điểm nữa đó là sự ưu tiên dành cho IPv6. Nếu máy của bạn đã cài IPv6 thì trình duyệt sẽ tự động ưu tiên cho giao thức này. Tuy nhiên vẫn có những lúc ngoại lệ, khi đó thì bạn cần phải khởi động lại trình duyệt.

Tổng kết về IPv6

IPv6 là giao thức mạng mang lại rất nhiều lợi ích cho người dùng và cả hệ thống Internet toàn cầu. Hiện nay các đơn vị đang dần dần chuyển đổi hoàn toàn từ IPv4 sang IPv6 nên để giúp các bạn bắt kịp với các hệ thống mạng, BKHOST đã hướng dẫn cho bạn những cách để cài đặt IPv6 đầy đủ nhất. Hãy áp dụng những hướng dẫn này để giúp ích cho mình trong việc cài đặt IPv6.


IPv6 là gì? 

Lịch sử ra đời của IPv6 (từ viết tắt của Internet Protocol 6) khá lâu. Đó là vào năm 1981, khi các máy tính hầu như chỉ có thể truy cập internet phục vụ cho các tổ chức nghiên cứu quân sự. Với môi trường làm việc 8 bit, kết hợp với không gian địa chỉ 32 bit do phiên bản Internet Protocol 4 (viết tắt là IPv4) cung cấp cho phép kết nối tới 4 tỷ địa chỉ khác nhau. 

Trải qua gần 30 năm, sự phát triển của công nghệ đã tạo bước đột phá, internet tồn tại trên khắp thế giới khiến con số địa chỉ đã gần đến mức cực đại. Đồng thời, nó còn dự báo có thể vượt giới hạn của IPv4. Về lý thuyết, nếu vượt mức trần thì khả năng kết nối internet sẽ không thể hoạt động được. Chính điều này đã thôi thúc việc nghiên cứu, phát triển giao thức mới, giúp hạn chế nhược điểm trên.

Đầu những năm 1990, IETF phát triển một giao thức mới có tên gọi là IP Next Generation (IPng). Và vào năm 1998, giao thức này chính thức chuẩn hóa, được Tổng công ty Internet cho tên miền và số (viết tắt là ICANN) phê duyệt, cho phép sử dụng trên rộng rãi trên toàn cầu. Giao thức được đặt tên IPv6 (RFC 1883).

IPv6 ra đời đã giải quyết được những hạn chế tồn tại của IPv4 trong hệ thống internet, tạo ra bước tiến nhảy vọt của công nghệ số.

Các điểm cải tiến của IPv6 so với IPv4:

Không gian lưu trữ lớn. IPv4 có không gian truy cập 32 bit, tương đương 4 tỷ địa chỉ. Còn IPv6 có không gian là 128 bit, lớn hơn gấp 4 lần so với IPv4. Độ bảo mật cao hơn. Khả năng định tuyến được tăng cao. Cấu hình được thiết kế theo hướng đơn giản hơn so với IPv4.
*

Lợi ích của IPv6 connectivity 

Các lợi ích mà IPv6 đã và đang mang đến cho người dùng đó là:

Cho phép không gian địa chỉ lớn, giúp việc quản lý không gian này trở nên dễ dàng hơn. Quản trị dễ dàng hơn. Do IPv6 có khả năng tự động cấu hình mà không cần đến máy chủ DHCP. Trong khi đó, IPv4 cần DHCP để cấu hình. Định tuyến IPv6 có thiết kế phân cấp nên cấu trúc tốt. IPv6 hỗ trợ tốt hơn về Multicast. Việc sắp xếp và định dạng header được thực hiện khoa học và tối ưu giúp việc bảo mật thông tin được cải tiến hơn. IPv6 hỗ trợ tốt cho các thiết bị di động.

Cấu trúc địa chỉ IPv6 

Cấu trúc của IPv6

Cấu trúc của một IPv6 gồm 128 bit, được phân thành 8 nhóm. Trong đó, mỗi nhóm có 16 bit và được phân chia bởi dấu “:”.

Một địa chỉ IPv6 được thể hiện theo cấu trúc sau:

FEDC:BA98:768A:0C98:FEBA:CB87:7678:1111:1080:0000:0000:0070:0000:0989:CB45:345F

Vì cấu trúc quá dài nên người ta thường bỏ số 0 ở đầu mỗi nhóm để rút gọn. Đối với nhóm nào chỉ có duy nhất dãy số 0 thì nó sẽ được biểu diễn bằng dấu “::”

*

Cấu trúc của Address Prefixes

Address Prefixes có cấu trúc tương tự IPv4 CIDR. Cách thể hiện của nó là IPv6-address/ prefix-length. 

Trong đó:

- IPv6-address: Địa chỉ IPv6 với giá trị bất kỳ.

- Prefix-length: Số bit liền kề nhau trong prefix.

Ví dụ: Quy tắc biểu diễn của 56 bit prefix 200F00000000AB là

200F::AB00:0:0:0:0/56

200F:0:0:AB00::/56

Lưu ý: Với địa chỉ IPv6, kí hiệu “::” chỉ được dùng duy nhất 1 lần trong một sự biểu diễn.

Các thành phần của IPv6

Địa chỉ IPv6 có 3 thành phần:

- Site prefix: Đây là thông số được gán với website thông qua ISP. Do đó, toàn bộ máy tính ở cùng vị trí sẽ chia sẻ với nhau bằng một site prefix. Có thể thấy, đặc tính của site prefix là khi đã nhận ra mạng của người dùng và cho phép truy cập thông qua internet thì nó sẽ hướng đến việc dùng chung. - Subnet ID: Đây là thành phần bên trong website. Nó được dùng để miêu tả cấu trúc site của mạng. Vì thế, một IPv6 subnet sẽ có cấu trúc tương đương một nhánh mạng đơn. - Interface ID: Cấu trúc của nó tương tự ID trong IPv4. Các thông số sẽ nhận dạng một host riêng. Interface ID có cấu hình tự động. 

Ví dụ: Địa chỉ IPv6 có cấu trúc: 2001:0f68:0000:0000:0000:0000:1986:69af bao gồm:

- Site prefix: 2001:0f68:0000

- Subnet ID: 0000

- Interface ID: 0000:0000:1986:69af
*

Phân loại địa chỉ IPv6 connectivity

Có 3 loại địa chỉ IPv6:

- Unicast: Một địa chỉ Unicast được chỉ định riêng cho một cổng của node IPv6. Khi có một gói tin gửi đến địa chỉ Unicast, nó sẽ được đưa đến cổng đã chỉ định bởi địa chỉ đó. - Multicast: Đây là nhóm các cổng IPv6. Khi một gói tin gửi đến địa chỉ Multicast thì nó sẽ được toàn bộ thành viên trong nhóm multicast xử lý. - Anycast: Đây là địa chỉ đăng ký cho nhiều cổng (tức trên nhiều node). Khi có gói tin gửi đến địa chỉ Anycast, nó sẽ được chuyển đến một cổng bất kỳ, tuy nhiên, phần lớn là đến cổng gần nhất.

Hướng dẫn cách đặt địa chỉ IPv6 cho win 7, 8, 10

Để đặt địa chỉ Ipv6 cho win 7, 8, 10, bạn thực hiện như sau:

Bước 1: Click vào biểu tượng Window, chọn tiếp Run. Trong cửa sổ Run, nhập dòng chữ ncpa.cpl. Bước 2: Bạn chọn card mạng muốn gán IPv6, sau đó chọn tiếp Properties. Bước 3: Tiếp tục chọn Internet Protocol Version 6 (TCP/IPv6), rồi chọn Properties.
*
Bước 4: Bạn tiến hành điền các thông số giá trị IPv6 của nhà cung cấp (tham khảo hình bên dưới). 
*
Bước 5: Sử dụng câu lệnh ipconfig ở cmd để thực hiện ping kiểm tra kết quả IPv6. Bằng cách, mở cmd, gõ tiếp lệnh ipconfig. Lúc này, một cửa sổ hiển thị như hình sau.
*

Kế đến, sử dụng dòng lệnh ping -6 ipv6.google.com để kiểm tra IPv6:

*

Nếu hệ thống hiển thị kết quả trả lời tức là bạn đã cài đặt thành công địa chỉ IPv6.

Hướng dẫn cách sử dụng IPv6 - đặt địa chỉ IPv6 thông qua Remote UI

Các thao tác thực hiện đặt địa chỉ IPv6 bằng cách sử dụng Remote UI được thực hiện như sau:

Bước 1: Bạn khởi động Remote UI và đăng nhập vào hệ thống. Bước 2: Click chọn thư mục Setting/Registration ở cột bên phải như hình sau.
*
Bước 3: Trong bảng hiện ra, click chọn Network Setting, rồi chọn tiếp TCP/ IP Settings.
*
Bước 4: Tại mục IPv6 Setting, bạn click chọn Exit.
*
Bước 5: Lúc này một bảng thoại xuất hiện. Bạn chọn hộp kiểm tra rồi tiến hành cấu hình cài đặt.
*
Bước 6: Khi đã hoàn tất cài đặt ở bước 5, bạn click OK để kết thúc cài đặt IPv6.

Cấu hình IPv6 trên Router Cisco

Các bước thực hiện như sau:

Bước 1: Tiến hành cấu hình IPv4, giao thức OSPFv2 trên các Router Thename và Thename1. Đây là những tên router giả định mà Hosting Việt đặt cho ví dụ minh họa sau để bạn dễ hiểu. Trong thực tế, bạn có thể đặt tên tùy ý theo nhu cầu sử dụng.

- Thename: 

Cú pháp câu lệnh thực hiện:

Thename#config terminal

Thename(Config)#interface fastethernet 0/0

Thename(Config-if)#ip address 192.168.12.1 255.255.255.0

Thename(Config-if)#no shut

Thename(Config-if)#interface loopback 0

Thename(Config-if)#ip address 1.1.1.1 255.255.255.255

Thename(Config-if)#no shut

Thename(Config-if)#interface fastethernet 0/1

Thename(Config-if)#no ip address

Thename(Config-if)#ipv6 enable

Thename(Config-if)#ipv6 address 2000::1/64

Thename(Config-if)#no shut

Thename(Config-if)#exit

Thename(Config)#router ospf 100

Thename(Config-router)#network 1.1.1.1 0.0.0.0 area 0

Thename(Config-router)#network 192.168.12.0 0.0.0.255 area 0

- Trên ISP:

Cú pháp câu lệnh:

ISP#config terminal

ISP(Config)#interface fastethernet 0/0

ISP(Config-if)#ip address 192.168.12.2 255.255.255.0

ISP(Config-if)#no shut

ISP(Config-if)#interface fastethernet 0/1

ISP(Config-if)#ip address 192.168.23.2 255.255.255.0

ISP(Config-if)#no shut

ISP(Config-if)#exit
ISP(Config)#router ospf 100

ISP(Config-router)#network 192.168.12.0 0.0.0.255 area 0

ISP(Config-router)#network 192.168.23.0 0.0.0.255 area 0

*

Hình trên là bảng định tuyến IPv4 trên Thename.

- Thename1

Cú pháp câu lệnh:

Thename1#config terminal

Thename1(Config)#interface fastethernet 0/0

Thename1(Config-if)#ip address 192.168.23.3 255.255.255.0

Thename1(Config-if)#no shut

Thename1(Config-if)#exit

Thename1(Config)#router ospf 100

Thename1(Config-router)#network 192.168.23.0 0.0.0.255 area 0

*

Bảng định tuyến IPv4 trên Thename1.

Lúc này, các mạng IPv4 đã có thể thấy và kết nối với nhau.

Bước 2: Tạo interface tunnel 0 trên Thename và Thename1 

- Thename

Câu lệnh:

Thename(config)#ipv6 unicast-routing

Thename(config)#interface tunnel 0

Thename(config-if)#ipv6 address 3000::1/64 eui-64

Thename(config-if)#no ipv6 nd suppress-ra

Thename(config-if)#tunnel source loopback 0

Thename(config-if)#tunnel mode ipv6ip isatap

Để kiểm tra Tunnel vừa tạo, bạn dùng lệnh show ipv6 interface brief.

*

Theo hình trên, Thename có địa chỉ IPv6 của tunnel 0 là 3000::5EFE:101:101

- Thename1:

Cú pháp câu lệnh như sau:

Thename1(Config)#interface tunnel 0

Thename1(Config-if)#ipv6 enable

Thename1(Config-if)#ipv6 address autoconfig

Thename1(Config-if)#tunnel mode ipv6ip

Thename1(Config-if)#tunnel source fastethernet 0/0

Thename1(Config-if)#tunnel destination 1.1.1.1

Để kiểm tra tunnel 0 vừa tạo, bạn cũng thực hiện câu lệnh tương tự như trên là dùng lệnh show ipv6 interface brief.

*

Theo bảng trên, địa chỉ IPv6 của tunnel0 trên Thename1 là 3000::C0A8:1703

Bước 3: Thực hiện định tuyến tĩnh trên các router IPv6 để các mạng con thấy nhau, bằng cách dùng câu lệnh ipv6 route x:x:x:x::x/ next-hop hoặc interface.

- Thename: Thename(config)#ipv6 route 4000::/64 3000::c0a8:1703

- Thename1: Thename1(config)#ipv6 route 2000::/64 3000::5efe:101:101

Sau đó, bạn kiểm tra các bảng định tuyến.

Hình sau là bảng định tuyến IPv6 trên Thename.

*

Dưới đây là bảng định tuyến IPv6 trên Thename1.

*

Bước 4: Thực hiện cài đặt IPv6 cho các host và ping để kiểm tra kết nối

Cách thực hiện như sau:

- Đặt IPv6 cho máy tính sử dụng Window Vista, 7, 8, 10, bạn thực hiện như hướng dẫn cách đặt địa chỉ IPv6 ở mục trên. Đó là vào Start / chọn Control panel / chọn tiếp Network and Internet / click chọn Network and Sharing Center /click mục Change adapter setting / và chọn Properties Local Area Connection / sau đó, click vào Internet Protocol Version 6 để cài đặt địa chỉ IPv6.

Đặt IPv6 cho máy tính sử dụng Window XP: Click vào nút Start / gõ Cmd trong thanh tìm kiếm / kích hoạt tính năng IPv6 bằng cách gõ câu lệnh “netsh interface ipv6 install”. Sau đó, dùng tiếp lệnh “netsh interface ipv6 add address “Local Area Connection” 2000::2/64” để đặt địa chỉ IPv6.
*

Sau khi hoàn tất đặt địa chỉ IPv6 cho host, bạn tiến hành ping để kiểm tra kết nối:

- Kiểm tra kết nối từ host 1 đến host 2

*

- Kiểm tra kết nối chiều ngược lại từ host 2 đến 1

*

Lúc này, 2 host đã thấy nhau. Đây là hướng dẫn về cách dùng cơ chế ISATAP thiết lập kết nối của IPv6 là gì. Mô hình mạng này tương đối đơn giản và bạn dễ dàng mở rộng với nhiều router khác nhau, kết hợp sử dụng định tuyến cao cấp hơn.

Ngoài ra, bạn cũng nên lưu ý là trước khi dùng ping để kiểm tra kết nối, bạn phải đảm bảo Window Firewall đã được tắt. 

Qua những thông tin trên Hosting Việt mong muốn có thể cung cấp cho các bạn cái nhìn tổng thể nhất về kết nối của IPv6 và các cách cài đặt IPv6 Nếu bạn có bất kỳ thắc mắc nào về việc cài đặt cấu hình IPv6 hãy comment phía bên dưới để chúng tôi giúp đỡ bạn nhé!